Jump to content

GPU Load 90 - 100%


Elith
 Share

Recommended Posts

  • Modz Gold Member

Hey guys, i wrote this same post on the 3dx official forum and since i didn't got no true solution i'm making this new thread here because a friend suggested me to do it so maybe different and experienced people can try to figure this out :(
 
Basically i got a brand new pc, a pretty good one that makes the games run like crazy so i've dowloaded 3DXChat to try how smooth it will run on this settings :D .

 

So when i've opened 3DXChat and i've checked at the task manager because i saw some sort of lag and my GPU Load was always full at 90-100% , even in the Login Menu without actually doing anything. When i'm in game it works pretty fine, it lags depending on the people or how much stuff there is in that room, but i really don't understand all this memory load on the graphic cards, plus i've tried to put all the specs to minimum and put the resolution down but that didn't changed much.

 

I've tried other games too like Warframe, Nier: Automata or The Witcher 3, Mad Max, but the gpu load doesn't even reach the 50 in some occasions.

 

Can you please help me figure this out :( ?

 

Every driver is up to date and my windows version is Windows 10 1709.

 

I've attacched a dxdiag in case you guys might need it.

DxDiag.txt

Edited by Elith
Link to comment
Share on other sites

Have you gone to the NVidia control panel and assigned the GPU to use highest performance on the 3dexchat.exe file? Did you build this system or was it prebuilt and bought? Whats the task manager saying that is using the highest load? I think Ayon posted how to find this data within the task manager.

Link to comment
Share on other sites

  • 2 weeks later...
  • Modz Administrators

Hi Elith

Thank you for your question.

I also run a Nvidia Card but have never hand an issue with GPU lag and my video card is 5 years old.

I'll open it tonight and see what its running at.

 

On 2/28/2018 at 4:51 AM, Chasan said:

Have you gone to the NVidia control panel and assigned the GPU to use highest performance on the 3dexchat.exe file

With this, in your Nvidia setting you should set (well I do :) ) in the "Global Setting" your card to run at the highest Power mode.

here is a screen shot

image.png

 

On 2/28/2018 at 5:24 AM, Chasan said:

itor it on what is using most of the CPU and MEMORY usage. One problem I used to have is running Chrome it made it lag alot.

The post I made about checking your Task manager was because people have many "Apps/Programs" running in the background and wonder why their computers are struggling.

If you know your way around computers and know what should and should not be running in the background then through the task manager you can monitor this and turn off the background "Noise"

 

However you said you are getting high "GPU load"...that is odd.

What are the graphics setting set at in game? Very High or Low?

Link to comment
Share on other sites

  • Modz Administrators

Elith

Sorry I just saw you uploaded your settings file.

 

Your GTX1070 should have Zero issue with this game.

I just want to check:

  • you are running your monitor at 2560 x 1440 (32 bit) (75Hz)?
  • Have you installed the 64bit Patch found here in the Modz forum for the game?

 

Link to comment
Share on other sites

  • Modz Gold Member

Yeah but no matter what resolution i put, I still have lag spikes specially in crowded rooms, I run any settings at low and I tried the 64bit patch in the 369 build but I didn't see any improvement what so ever. I'm on a Windows 10 build 1709, might that be the issue ? Online I've heard that it's causing everyone problems with optimization and stuff.

Link to comment
Share on other sites

Guest Chasan

I am running Windows 10 build 1709

 

as long as I am not running too much in the background I do not lag whatsoever. My card is a NVidia GTX 1080 Ti and I have 32 gigs of ram. I hardly ever lag, and if I do its cause of the net not my hardware.

Link to comment
Share on other sites

  • Modz Gold Member

Then I don't know what might be the issue for me, the game for me is not stable depending on what I look at. If look at the sky I got like 10% of GPU load and if I look at a group of people I'm always at 70-100%. It's like I miss something installed but it's the only game that behave like this... I don't know what other info you guys might need to help me out now.

Link to comment
Share on other sites

  • Modz Administrators

Hi there

This is 3DX in my Closet

image.png

 

This is in a room with 30+ people

 

image.png

 

Have you tried using a different Monitor with your new computer?

Link to comment
Share on other sites

  • Modz Administrators

Well it seems you have a strange problem so i hope we can help you out.

The task manager review is just a start to help find your problem.

 

I assume you have set your Antivirus to Allow 3DX?

normally your antivirus would just not allow the game to run, but i know some software will check all the in going and out going data and that will slow any game down.

Link to comment
Share on other sites

  • Modz Administrators
20 minutes ago, Chasan said:

Defender should not effect 3dx cause I am running it also

Agree, Defender should not be the problem, but if you can set the exclusion for 3DX in Defender it will eliminate it as a problem :)

 

Link to comment
Share on other sites

  • Modz Gold Member

Ok guys i managed to return back home to show you this.

 

This is when i'm in the menu idle and if i move the task manager around I noticed that my csrss.exe spikes up from time to time making my gpu load even more to 70%

 

https://imgur.com/a/sCkup

 

Edited by Elith
Link to comment
Share on other sites

  • Modz Administrators

Hi Elith

Thank you for the information.

 

I googled "csrss.exe causing hi GPU load" and it seems its a common problem and most of the forums I read point towards maleware being the problem.

It seems some maleware  hides using the csrss.exe name within your windows system and as its name is shared with a windows process most antivirus programs ignore it.

 

In your task manager check that there is not two csrss.exe process running.

 

Also google possible fixes for "csrss.exe causing hi GPU load" as i found a lot when I just looked :)

 

please let us know how you go with this as a possible fix <3

 

Link to comment
Share on other sites

  • Modz Gold Member

Yeah I had that same kind of research a while ago and I checked for malwares with both Malwarebytes and Spybot Search and Destroy, but still nothing unusual or found. 

I also noticed that this Csrss.exe acts while I'm in the normal desktop too. Like when you hold your left click on the screen and do squares with the select area I see the GPU Load raising for no reason to 40 or 60 depending on how big the square is and immediately return to 0 when I stay put or stop holding O.o It's very weird right ?

Link to comment
Share on other sites

  • Modz Administrators
14 minutes ago, Elith said:

It's very weird right ?

Yes, its very weird.

So i think you have a Windows problem and not a 3DX problem.

Some of the forum suggest that you start your windows in "Safe Mode" and run the maleware scan because the csrss.exe is a windows process you need to use "safe mode" to find the virus.

Link to comment
Share on other sites

  • Modz Gold Member

I had a little update like yesterday if I remember vorrectly... So I should run a malware scan in safe mode ? :)

I'll keep you updated tomorrow ^^ do you know how to get into safe mode ?

I had a little update like yesterday if I remember vorrectly... So I should run a malware scan in safe mode ? :)

I'll keep you updated tomorrow ^^ do you know how to get into safe mode ?

Link to comment
Share on other sites

  • Modz Gold Member

Ok i managed to do it but sadly no malware on the Csrss.exe T_T i also saw that putting the fps locked to 30 kinda improve the load on the gpu, too bad it's not so smooth :/

Link to comment
Share on other sites

  • Modz Gold Member

When it's idle in the character selection I have like 20-30% and depending on the room or where I'm looking I got spikes to 70 or 90, I guess I still have to blame the unity engine for this... I mean all other games run pretty smoothly and even after this patch they did the game it's still the same to me. I don't think there is a solution to this problem but blaming the game itself :/

Link to comment
Share on other sites

Guest Chasan

for now, until further analysis I agree with you. The unity engine maybe whats spiking it. Probably Alex may have a solution that maybe more elaborate.

Link to comment
Share on other sites

Guest Chasan

crss.exe is a system runtime server service that is required for windows to run. We all run it when we are in windows. Since the scan has been done and nothing was found, I do not think we can pin point that in being the problem. I could be wrong, but the only alternative would be in my opinion is to reinstall Windows 7 from scratch, and do a secure erase on the HDD. Then reinstall the OS and make sure the latest drivers for all the devices are installed before reinstalling the game itself. Aga, I could be wrong in this, but its just my own personal thoughts.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



  • Google Translate

×
×
  • Create New...

Important Information

By using and viewing this site, you agree to our Terms of Use.